[IE9] Bug graphique : Bannière en double

réglement, evolutions, droits et devoirs du forumeur

Modérateur: Morrock

[IE9] Bug graphique : Bannière en double

Messagepar The Shadow of Death » Jeu 16 Sep 2010, 15:34

Tout est dans le titre =) Avec la bêta qui vient de sortir (et qui est tout bonnement géniale, rien à voir avec ses prédécesseurs), je viens me promener sur le forum AC et que vois-je :shock: Il y a deux bannières en haut.
Ceci doit venir de là je pense :
Code: Tout sélectionner
<!--[if gte IE 7]>
                     <a href="./index.php" title="Index du forum" id="logo"><img src="./styles/AC_H6/imageset/headerh6.png" width="946" height="260" alt="" title="" /></a>
                  <![endif]-->
                  <!--[if lte IE 6]>
                     <a href="./index.php" title="Index du forum" id="logo"><img src="./styles/AC_H6/theme/images/headerh5.gif" alt="logo AC" /></a>
                  <![endif]-->
                  <comment>
                     <a href="./index.php" title="Index du forum" id="logo"><img src="./styles/AC_H6/imageset/headerh6.png" width="946" height="260" alt="" title="" /></a>
                  </comment>

Le <comment> peut-être ?
Et je le dis déjà aux détracteurs : non le problème n'est pas IE 9, j'étais le premier à déconseiller tout le monde d'utiliser les précédents mais là, il dépasse de loin Chrome et rivalise avec Firefox (un minuscule chouia plus rapide [en gros] que la dernière version beta de Firefox) ;)
Inutile de vous lamenter, votre code ne marchera jamais. En effet, il n'a jamais reçu la capacité de se déplacer.
Avatar de l’utilisateur
The Shadow of Death
Maître
Maître
 
Messages: 722
Enregistré le: Mer 5 Juil 2006, 15:18
Localisation: Dans son Caveau Royal

Re: [IE9] Bug graphique : Bannière en double

Messagepar Nelgirith » Jeu 16 Sep 2010, 15:47

The Shadow of Death a écrit:Et je le dis déjà aux détracteurs : non le problème n'est pas IE 9

Si c'est un problème qui n'apparait que dans IE9 alors le problème est très certainement lié à IE9. :roll:

Après ... moi, je dis qu'il faut être vraiment suicidaire pour surfer avec du gruyère :twisted:
Image
Avatar de l’utilisateur
Nelgirith
Grand Maître
Grand Maître
Responsable
Responsable
 
Messages: 3736
Enregistré le: Jeu 29 Sep 2005, 13:01
Localisation: En train de boire un pot avec Dédale

Re: [IE9] Bug graphique : Bannière en double

Messagepar Morrock » Jeu 16 Sep 2010, 22:41

Le problème ne vient pas spécifiquement d'IE 9, il vient des incompatibilités entre les différentes versions d'IE et le non respect des standards par le navigateur de façon générale. C'est donc IE dans son ensemble qui est à incriminer.

Jusque là, les différentes balises se succédant (gt IE7, lte IE6, comment) permettaient d'avoir l'affichage sur toutes les versions d'IE (avec les deux premières balises) et sur tous les autres navigateurs (avec la dernière).
C'était en soi une aberration de code html, mais le seul moyen de contourner le fait qu'IE 6 et précédents étaient incapables de gérer la transparence des fichiers .png.

Apparemment, IE 9 ne comprend plus la balise <comment>, qui lui dit d'ignorer le code qu'il contient... faudra que je réfléchisse à une autre façon de faire, mais très honnêtement, je n'ai pas franchement envie de me casser la tête pour une ènième version de code non-conforme aux standards issus de Cro$oft.

Donc j'y regarderai pour voir ce que je peux faire, mais je ne sais pas quand et je me permets de ne pas le mettre dans les urgences. Surtout pour une version beta, peut-être que le problème sera corrigé dans la prochaine version d'IE.
Ci-gît la signature de Morrock, exterminée par une défaillance de disque dur...
Avatar de l’utilisateur
Morrock
Grand Maître
Grand Maître
Administrateur
Administrateur
 
Messages: 3079
Enregistré le: Ven 9 Juin 2006, 12:24
Localisation: Erre dans les couloirs du châteaux à la recherche de chair fraîche


Retourner vers Site et Forums



Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité